Microchip Minutes: helloWorld Application Lab
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Overview

The purpose of this lab is to introduce basic concepts of how to set up a project in MPLAB® X
IDE while using the MPLAB Code configurator to light an LED connected to one of the pins of a
PIC16F1619 microcontroller. This is commonly known as the helloWorld application.

Equipment Needed

This lab was developed using the following tools:

Hardware:
- Curiosity Development Board: www.microchip.com/curiosity
o Page includes user’s guide along with schematics and other helpful information.
- PIC16F1619 8-bit PIC® microcontroller:
http://www.microchip.com/wwwproducts/Devices.aspx?product=PIC16F1619

Software:
- MPLAB X IDE : www.microchip.com/mplabx
- MPLAB XC8 C Compiler: www.microchip.com/xc8
- MPLAB Code Configurator (MCC): Please see How to install MPLAB Code Configurator
(MCC) at the end of this lab.



http://www.microchip.com/curiosity
http://www.microchip.com/wwwproducts/Devices.aspx?product=PIC16F1619
http://www.microchip.com/mplabx
http://www.microchip.com/xc8

Procedure

Create a new project:

1. Open MPLAB X IDE

2. Create a new project by clicking the New Project icon = or by selecting File>New
Project...

3. Inthe New Project window select Microchip Embedded in the Categories: frame and
Standalone Project in the Projects: frame and click Next.

Ew Project R — g
Steps Choose Project
1. Choose Project Categories: Projects:
2 . ud‘,ﬁ,bmd 5 standalone Project
i..[J} Gther Embedded & Existing MPLAB IDE v8 Project
), Samples [ Prebuilt (Hex, Loadable Image) Project

[ User Makefile Project
(&4 Library Project

Description:

Creates a new standalone application project, It uses an IDE-generated makefile to build your
project.

MNext > Finish Cancel ][ Help

4. Select the Mid-Range 8-bit MCUs (PIC10/12/16/MCP) in the Family dropdown in the
Select Device window and then select PIC16F1619 in the Device dropdown. Click

Ew T e ——
Steps Select Device
1. Choose Project
2. Select Device
3. Select Header Famiy: id-Range -bit MCUs (PIC10/12/16MCP) +
4. Select Tool
5. Select Plugin Board
& Select Compier Device: PICI6F1619 -
7. Select Project Name and

Folder

< Back ] [ MExt > Finish Cancel ] [ Help




5. Select the Curiosity Board in the Select Tool window and click Next>.

2

3 New Project

Steps Select Tool

1. Choose Project
2. SelectDevice |/ Hardware Tools
3. Q2 ICD 3
@ PICKit2
-0 PICKit3
-0 PM3
00 Re...
-0 Simulator
- | Microchip Starter Kits
[ Starter Kits (PKOB)
& | Legacy Start...
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< Back H Mext = ] Finish [ Cancel H Help

6. Next, select the XC8 compiler in the Select Compiler window and click Next>.
’x New Project (s |

Steps Select Compiler
1. Choose Project
2. SelectDevice Compiler Toolchains
3. SelectHeader [=-mpasm
4, Select Tool © i.ompasm (v5.62) [C:\Program Files (x36)Microchip\MPLABX 3. 05\mpasm:]
5. SelectPlugin Board B XC8
6. Select Compiler i = e = e
7. SelectProject Name and LT C3 (v1.34) [C:\Program Files (x86) Microchip\xc8 v 1. 34'pin]
i Folder i

< Back H Mext > ] Finish [ Cancel H Help




7. Select a project location and name the project to something meaningful such as
helloWorld. Be sure that the check box next to Set as main project is selected and

click Finish.

3 New Project

Steps

Select Project Hame and Folder

Choose Project
Select Device
Select Header

Select Tool

Select Piugin Board

Select Compiler

Select Project Name and
Folder

NoOmswNe

Project Name: heloworld
Project Location: C:\Users\c13137\WPLABXProjects
Project Folder: C:\Users\c13137\MPLABXProjectsthelloVorld. X

Overwrite existing project.
Also delete sources.
Set as main project
[ Use projectlocation as the project folder

Encoding: 150-8858-1 -

Browse...

8. The MPLAB X IDE workspace should look similar to below. If not, common windows

such as Projects can be opened through Windows>Projects etc...
— T
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Setup MPLAB Code Configurator (MCC) to Generate Code

1. Open MPLAB Code Configurator (MCC) from Tools>Embedded>MPLAB Code Configurator.
If the MCC is not listed or if the Tools>Embedded menu isn’t listed, then MCC will need to
be installed (see How to install MPLAB Code Configurator at end of manual)

2. Opening the MCC for the first time will display an overlay describing key sections of the
workspace including Project Resources, Device Resources and Composer area. The reader
is encouraged to take a moment to familiarize themselves with these sections. The overlay

can be closed by hitting the ESC key and reopened anytime by selecting the & button.
€ MPLAB X IDE v2.05 - helloWorid : defauic T — = = = R

Press "ESC" to close the overlay

Project Resources Area
Composer Area
All the peripherals which were
selected and configured are
displayed here. Clicking on one of
the entries will display the Ul in the
"Composer Area ->"

Device Resources Area

All the available and supported . _ . : .
peripherals for the selected device In this area you will see the UI for the peripheral you have selected in the "<- Project

are displayed here. Expanding the Resources Area'. Here you will find all settings which you can configure for the
nodes will reveal instances and selected peripheral
different modes of operation.

Other buttons in the MCC include:

|| Accesses the MCC Homepage and Forums

ua| Accesses Options to customize how the MCC behaves. These labs will use the default
configuration



3.

In the Project Resources area, select the System resource to open the user interface in
the composer area.

roject Resources

- System Generate Code (2)

E| |45 Initialize +|[x
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bfﬂ Current dlock: 500.0 KHz
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The system user interface is where core device operational parameters are setup such as
oscillator selection and enabling or disabling features such as brown-out reset, windowed-
watchdog use and so on.

Configure the system to use the INTOSC (Internal Oscillator) from the System Clock Select
drop-down menu. The Internal Clock set to 500KHz_HF default can be left as is.
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In the bottom section of the Composer Area is where fuses or configuration bits are set.
Here the Microcontroller will need to be configured to use Low Voltage Programming. This
is the programming mode used by the integrated programmer/debugger on the Curiosity
Board.

Expand the CONFIG2 drop down and select the radio button next to the Low-voltage
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programming enabled selection under the Low-Voltage Programming Enable [LVP ON]
sub category.

Q) |search for fuse...
Generate Configuration Bits

[#-CONFIG1

=-CONFIG2

--Flash Memary Self-Write Protection [WRT OFF]
--Ll::w-Puwer Brown Out Reset [LPBOR OFF]

:I -Peripheral Pin Select one-way control [PPS IWAY OM]
EI Low Voltage Programmlng Enable [LVP OM]

|

: " ngh—uohﬁge on MCLR VPP must be used for programming
l -Zero Crnss Detect Disable Bit [ZCD OFF]

_l -Stack Overflow,Underflow Reset Enable [STVREM ON]
[#-PLL Enable Bit [PLLEN QN]

[#1-Brown-out Reset Voltage Selection [BORV LO]
[#-CONFIG3

A General Purpose I/0 pin will be driven HIGH to light an LED connected to it. In the
Device Resource Area, locate and expand the GPIO drop-down and double-click on the
GPIO::GPIO selection to add to the Project Resources Area.

Device Resources - PIC16F1619
ADC
AT
ccpP
ac
CRC
CWG
Comparator
DAC
EUSART
FVR
GPIO
MSSP
Math Accelerator

- (- - - - - - £

Offs -%7) I ECROVI2 OP

B



Select GPIO::GPIO in the Project Resources Area to open the GPIO peripheral user
interface in the Composer Area.

Hie bdit View Navigate Source Kefactor Kun Debug leam lools Window Help
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iProjects | Files [; classes iMPL. @ || StertPage | MPLAB® Code Configurator | [E3) (=) [E] [; mPLAB® Code Configurator Fin Manager 3
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Note that an additional area appears called the MPLAB Code Configurator Pin Manager.
This area provides a graphical representation of the selected device along with available
pins for the selected peripheral in blue. Pins are assigned by selecting the desired pin in the
lower section of the area.

Ensure that the appropriate package is selected in the Pin Manager using the Package
drop-down menu. This lab utilizes the Curiosity board populated with a PIC16F1619 in 20-
pin PDIP package.

: MPLAB® Code Configurator Pin Manager o

¢ MicrocHie 15
T PIC16F1618 14
]
3
10

=] Reverse Pin Order

19| 13| 17| 4 | 3| 2 | 13| 12| 11| 10| 16| 15| 14|

PORTAY PORTEY

Module Function L0 - s 0 0 . - L3 a3 e ) =3




8. Referring to the Curiosity Board schematic, LEDs are connected to RC5 (PORTC bit 5), RA2
(PORTA bit 2), RA1 (PORTA bit 1) and RA5 (PORTA bit 5) I/O pins. Select one of these by
clicking on the appropriate pin in the lower Pin Manager window. Here RC5 connected to
LED D7 is selected. Note the changes in the Pin Manager with the pin selected now
appearing green with a lock icon'.

MPLABE Code Configurator Pin Manager |

& MicrocHP 18
7 PIC16F1618
8

F S

Package :PDIPZU - Reverse Pin Order

X | X |16/15/14 7| 6| 5| 8| 9

Aw EM PORTC¥

Module Function X X o123 |4|5|6|7

G| 1o "B BBABRE

9. Pin names can be changed by the user so that they are easier to identify. In the Composer
Area, configure the I/O pin as an output by checking the appropriate box and change the
name to something meaningful such as led.

Generate Code (2)

rSelected pins: 1

Fin Mo. Output StartHigh WPUE IOC IOCP IOCM Custom Mame

Res 5 | W | @ | | |00 EE

& [ E cpio::6PIO




Next, click on the Generate Code button in the Composer Area to generate the necessary
C code that corresponds to the configuration setup in the MCC.

Generate Code (2) ]

Selected pins: 1
Fir Mo, Output StartHigh v
RCS |5 | | |

GPID::GPID

Note that the MCC will ask if the user would like to generate a main.c file if one doesn’t
already exist. In this instance, click Yes.

rx No main.c detected @

MCC detected you do not have a main.c file,
Would you like to generate ene (This is a one time question)?

10. The Output — MPLAB Code Configurator window at the bottom of MPLAB X IDE should
indicate that code has been generated successfully. If the Output window is not visible it
can be opened by selecting Window>Output>Output.

: Output - MPLAB® Code Configurator L] |

Code for Pin Manager was successfully generated
Code for System was successfully generated

Code for main was successfully generated

Fhbdiis Ceneration ended #RREssss

Fhdkdkks Ceneration started FhEeRess
Number of files to be generated: 4

Code for Pin Manager was successfully generated

Code for System was successfully generated

whkwwww Ceneration ended wvesssss
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11. Compile the project and download to the PIC16F1619 by clicking the Make and Program
Device Main Project button in the MPLAB X IDE Workspace.

Output 2 |
| MPLAB® Code Configurator = | helloWorld (Build, Load, ...) s | Starter Kiton Board 5 L

Target detected
Device ID Revision = 2003

The following memory area(s) will be programmed:
program memory: start address = Ox0, end address = Ox7£f

configuration memory

Programming. . .

Programming/Verify complete

Result
If configured correctly, the LED D7 on the Curiosity Board should light.

Note: If MPLAB X IDE displays a window indicating the target device is not recognized,

low-voltage programming may need to be enabled in the project properties.
(3¢ MLz =)

Target Device ID (0x0) does not match expected Device ID (0x307d). Would you
l % like to continue?

[71 Do not show this message agairt
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Enable Low-Voltage Programming Mode in Project Properties

1. Open File>Project Properties (helloWorld)

In the Project Properties window, highlight Starter Kit (PKOB) in the Categories pane.

3. On the right side of the Project Properties window, select Program Options from the
Option categories: drop-down menu

N

B€ Project Properties - helloWorid
ateaories: Options for Starter Kit (PKOB]
w- @ General I S
£ @ Conf: [default Option categories: | Memories to Program ~
i @ Starter Kit (PKOB) IMemories to Program T ——
- @ Loading Auto select memorie SRR Allow PICKit 3 to Select Memor
~ @ Libraries Configuration Memod_MWare
i~ @ Buiding o
B+ @ XCB global options
i@ XCB compiler Program Memory
b @ XCB linker Program Memory Start (hex) 0x0
Program Memory End  (hex) O 1FFF
Preserve Program Memory D
Preserve Program Memory Start (hex) 0x0

4. Make sure that the checkbox next to Enable Low Voltage Programming is selected. Even
if the checkbox is selected click Apply and then OK to close the window.
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How to install MPLAB Code Configurator (MCC)

1. Select Tools>Plugins
2. Inthe Plugins window select the Available Plugins tab, locate the MPLAB Code

Configurator and ensure the checkbox under Install is selected. Click Install to
install the plugin.

| S ——

< | Avalable Plugins (23) | Downloaded | Installed (25) [ settings|
Reload Catalog Search:
Instal  Name Category ¥ Source
MPLAB® Code Configurator

[ omcr MPLAB Plugin o - fig

[ pctint MPLAB Plugin I i Community Contributed Plugin -
[] MPLAB®Harmony Configurator  MPLAB Plugin @ 7
[7]  Power Monitor MPLAB Plugin 77 Version: 2.10.3 =
[[] EFviewer MPLAB Plugin G Author: Micachip Technology Inc. L
[[]  MPLABX KeeLog Plugin MPLAB Plugin & Date: 3/12/15

[7]  Code Profiing (Trial Version) MPLAB Plugin 77 Source: Microchip Plugins

[[] ECANEitRate Caleulator MPLAB Plugin &a Homepage: hitp:/fwww.microchip.com/mee

MPLAB® Code Configurator MPLAB Plugin i

(7] Graphics Display Designer X MPLAB Plugin ) Plugin Description

[7]  MemoryStarterkit MPLAB Plugin b

D dsPICWorks MPLAB Plugin m E ;thMPLABEde:: Cnnﬁgurah;t’ ETCC)hg‘EHErahEﬁs sEEmlEsds e;sy to un;?’s‘fnfd Ceode

e s S iats inserted into your project. It enables, configures and utiizes a rich set o

g sy od s VoD o 0 peripherals across a select it of devices, Its integrated into MPLAB X (IDE) ta provide

] fewer (FreeRTOS) ugin I 2 very powerful and extremely easy to use development platform.

[[]  PathTools Netbeans Plugin i

[[]  FormatMany Netbeans Plugin 77 System requirements

[F] PP Tool Chain Tools b

[[]  PicBasic Language Syntax Tools ) : rg';‘s 1x ‘3:1‘ 2

[F]  €C5 ¢ Compiler Tools 77 @ XC16: V124

] sDCC Tookhain Tools @ L

[[]  Proteus VSM Viewer Tools 7 -

1 plugin selectad, 38

3. Click Next>in the Plugin Installer window
" Plugin Installer [ = T

‘Welcome to the Plugin Installer
The installer will download, verify and then install the selected plugins.

The following plugins will be installed:

MPLAB® Code Configurator [2.10.3]

< Back Help
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4. Check next to | accept the terms in all of the license agreements and then click
the Install button to install MCC.
x Plugin Installer &

-

License Agreement
Please read all of the following license agreements carefully.

In order to continue with the installation, you need to agree with all of the license agreements associated
with the particular plugins.

MPLAB® Code Configurator License Agreement
Copyright (C) [2012-2015] Microchip Technology Inc. and ite subsidiaries (Microchip). Tl

»

All rights reserved.

m

You are permitted to use the accompanying software and its derivatives with Microchip products.
See the Microchip license agreement accompanying this software for additional info regarding your
rights and obligations.

MICROCHIP SOFTWARE AND DOCUMENTATION ARE PROVIDED "AS IS™ WITHOUT WARRANTY OF
ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITATION, ANY WARRANTY OF
MERCHANTABILITY, TITLE, MON-INFRINGEMENT AND FITMESS FOR A PARTICULAR PURPOSE. IN

RO EWELT WAITLL MTEOACWTO AN TTE | TCEMCANE BE | TARLE A0 AL TEATED LIMOED SO AT

I accept the terms in all of the license agreements,

’ < Back ][ Install ][ Cancel ] Help

5. MPLAB X IDE will need to be restarted in order to complete plugin installation. Click
Finish to restart the IDE
rn Plugin Installer - — @1

Restart application to complete installation
Restart application to finish plugin installation.

The Plugin Installer has successfully installed the following plugins:
MPLAB® Code Configurator

(@) Restart Now
() Restart Later

Restarting the IDE may take a minute or two.
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6. Once restarted, MCC should now appear in the Tools>Embedded menu.
Window Help

Embedded ’@) MPLABE Code Configurator |

= Licenses 4

4 Add to Favorites

Templates

DTDs and XML Schemas

Plugins

Options
|
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